Hobart Welders
Home » Weld Talk
Weld Talk Message Boards - Powered by vBulletin

Page 2 of 2 FirstFirst 1 2
Results 16 to 22 of 22
  1. #16
    Join Date
    Jan 2017
    Posts
    13
    I have done a lot of soldering and would have done this in a jiffy. I worried that if the diode wasn't the fix and I did an ugly job with that conformal coating a repair company would not fix it. York Electronics said they would fix it for 185 dollars plus shipping so I just boxed it up and shipped it to them. They will have it Friday. Hopefully they will go through everything and get everything fixed so I don't have to mess with it again.

    I appreciate everyone's help with this issue and will post back success or failure with York Electronics. I found a good review for them and their price was somewhat reasonable for a 2 dollar diode. I hope it works out.
    Hobart 190 mig welder 13 months old still in the box
    champion 10k welder/generator- on the to do list

  2. #17
    Join Date
    Jun 2012
    Location
    Almost Paradise
    Posts
    402
    Quote Originally Posted by hydroax View Post
    I have done a lot of soldering and would have done this in a jiffy. I worried that if the diode wasn't the fix and I did an ugly job with that conformal coating a repair company would not fix it. York Electronics said they would fix it for 185 dollars plus shipping so I just boxed it up and shipped it to them. They will have it Friday. Hopefully they will go through everything and get everything fixed so I don't have to mess with it again.

    I appreciate everyone's help with this issue and will post back success or failure with York Electronics. I found a good review for them and their price was somewhat reasonable for a 2 dollar diode. I hope it works out.
    I've never spoken with York but know several whom have used their services for various items. They will put that CCA through a battery of tests to reveal anything you may not have come across yet. It very well may fail in another area and will be repaired then.

    I've heard nothing bad about them myself but turnaround time can be slow at times. However that being said, some are over anxious once they send their part in for a repair to process so be patient if possible.
    Thanks for reading/listening.

    Antique Hobart Engine Drive Lover X5

  3. #18
    Join Date
    Jan 2017
    Posts
    13
    I hope your right. There is not much to the board, and they should be able to load it down. The physical Hobart generator looks really beefy and the Koehler engine runs like it is new. I have the same engine on one of my t30 compressors. I picked up this machine for 500 bucks so 200 dollars to work the bugs out still keeps me in the win column. I am anxious to get it going so I can plug my 190 mig into it and see how it runs. we shall see.
    Hobart 190 mig welder 13 months old still in the box
    champion 10k welder/generator- on the to do list

  4. #19
    Join Date
    Jan 2017
    Posts
    13
    Quote Originally Posted by canoecruiser View Post
    This will most likely remove the conformal coat: https://www.zoro.com/techspray-confo...g&gclsrc=aw.ds

    It is also available from Allied Electronics for a few dollars more: http://www.alliedelec.com/techspray-...FcZKDQodtJ8F7w

    This diode is a drop-in replacement and is rated for 6 amps; the reverse voltage rating is the same at 1000 volts: http://www.alliedelec.com/nte-electr...FY5WDQodQKsNTg. Any silicon diode with equivalent or better ratings to what Keith referenced will work fine.

    Before removing the existing diode, note which way it is oriented by identifying the cathode (should have a band around one end of the body). It sounds like you have experience with electronics so you should be in good shape.

    If I had seen this conformal remover before I shipped it out I would have given it a go for sure. that's an awesome tip thanks! Hopefully I wont have to repair anything in the near future
    Hobart 190 mig welder 13 months old still in the box
    champion 10k welder/generator- on the to do list

  5. #20
    Join Date
    Nov 2010
    Location
    Maryland
    Posts
    852
    I've read that the Champion 10K is very similar to the Miller Bobcat line of engine drives. Hobart and Miller have the same corporate parent. Some of the Millers' reputedly have a design flaw (a serious one IMO), in that if the battery is dead and you jump-start them from an external power source, it takes out a diode and then after it is running....there is no output due to no field excitation. The Millers, reportedly do not suffer any damage other than to the diode resulting from this step. I am not familiar with either engine drive and don't know first-hand how similar they are to one another.

    The reason I state it is a serious design error is that if it is only used intermittently, a dead battery could be a likely occurrence, and jump-starting is a typical remedy to get it running immediately. If you need it to be reliable, say for emergency power, keeping the battery inside on a maintenance charger and connecting it as required would prevent any possibility of this happening.
    CanoeCruiser
    Harris dual-stage O/A
    Lincoln AC/DC buzzbox
    Hobart IronMan 210
    Lincoln PowerMig 135
    Miller 3035 spoolgun
    Thermal Arc 185
    Thermadyne Cutmaster 52
    Angle grinders, vicegrips, the usual suspects
    Two hands, tired body, not enough time...

  6. #21
    Join Date
    Jan 2017
    Posts
    13
    Well I intercepted the board and replaced the diode with a nte5817 and soldered it in. No joy, then it let the smoke out of a trace. Bad day.

    Im banking someone has seen this trace go before, which indicates something wrong with wire 20 or a engine regulator or diode. I am holding off doing anything till I get some feedback from you pros. The trace will be easy to fix but I certainly don't want to mess anything else up with this board.

    Should I be able to run the engine with no card and verify the voltage from the regulator? Im thinking that was going out.

    Update: regulator fine, stable, 12 volts from engine is good. checked wiring, everything looks fine. Checked the diodes on the board, all check good. D23 checked good before I replaced it. something's breaking down and it doesn't look like I am going to find it.


    20170112_195024[1].jpg
    Attached Images Attached Images
    Last edited by hydroax; 01-12-2017 at 09:01 PM.
    Hobart 190 mig welder 13 months old still in the box
    champion 10k welder/generator- on the to do list

  7. #22
    Join Date
    Nov 2010
    Location
    Maryland
    Posts
    852
    Hydroax, check your in-box for a PM.
    CanoeCruiser
    Harris dual-stage O/A
    Lincoln AC/DC buzzbox
    Hobart IronMan 210
    Lincoln PowerMig 135
    Miller 3035 spoolgun
    Thermal Arc 185
    Thermadyne Cutmaster 52
    Angle grinders, vicegrips, the usual suspects
    Two hands, tired body, not enough time...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •